update_woo_com_subscription_details

update_woo_com_subscription_details

Appears in:
Hook Type: filter

See hook in core

Displaying hooks found in version: woocommerce.8.8.3

apply_filters('update_woo_com_subscription_details') is found 2 times:

  • /includes/admin/helper/class-wc-helper-updater.php line 79
    			 * @param array $item Plugin item to modify.
    			 * @param array $data Subscription data fetched from Helper API for the plugin.
    			 * @param int   $product_id Woo product id assigned to the plugin.
    			 */
    			$item = apply_filters( 'update_woo_com_subscription_details', $item, $data, $plugin['_product_id'] );
    
    			if ( isset( $data['requires_php'] ) ) {
    				$item['requires_php'] = $data['requires_php'];
    			}
    
    			if ( $transient instanceof stdClass ) {
    
  • /includes/admin/helper/class-wc-helper-updater.php line 139
    			 * @param array $item Plugin item to modify.
    			 * @param array $data Subscription data fetched from Helper API for the plugin.
    			 * @param int   $product_id Woo product id assigned to the plugin.
    			 */
    			$item = apply_filters( 'update_woo_com_subscription_details', $item, $data, $theme['_product_id'] );
    
    			if ( version_compare( $theme['Version'], $data['version'], '<' ) ) {
    				$transient->response[ $slug ] = $item;
    			} else {
    				unset( $transient->response[ $slug ] );
    				$transient->checked[ $slug ] = $data['version'];
    
update_woo_com_subscription_details - WordPress Hooks

update_woo_com_subscription_details

update_woo_com_subscription_details

Appears in:
Hook Type: filter

See hook in core

Displaying hooks found in version: woocommerce.8.8.3

apply_filters('update_woo_com_subscription_details') is found 2 times:

  • /includes/admin/helper/class-wc-helper-updater.php line 79
    			 * @param array $item Plugin item to modify.
    			 * @param array $data Subscription data fetched from Helper API for the plugin.
    			 * @param int   $product_id Woo product id assigned to the plugin.
    			 */
    			$item = apply_filters( 'update_woo_com_subscription_details', $item, $data, $plugin['_product_id'] );
    
    			if ( isset( $data['requires_php'] ) ) {
    				$item['requires_php'] = $data['requires_php'];
    			}
    
    			if ( $transient instanceof stdClass ) {
    
  • /includes/admin/helper/class-wc-helper-updater.php line 139
    			 * @param array $item Plugin item to modify.
    			 * @param array $data Subscription data fetched from Helper API for the plugin.
    			 * @param int   $product_id Woo product id assigned to the plugin.
    			 */
    			$item = apply_filters( 'update_woo_com_subscription_details', $item, $data, $theme['_product_id'] );
    
    			if ( version_compare( $theme['Version'], $data['version'], '<' ) ) {
    				$transient->response[ $slug ] = $item;
    			} else {
    				unset( $transient->response[ $slug ] );
    				$transient->checked[ $slug ] = $data['version'];